Mon. - Fri. 9 am - 5 pm Ask a Question
Remember me

There are no images from gallery on Google!?

3 weeks 3 days ago #1

  • Ivan's Avatar
  • Ivan
  • Posts: 12
Hi, I have a problem with Gallery images not being indexed by search engines... When I google website or keywords none of the images from Gallery appears within search!

What should I do to make images visible on Google?

For example, you can see website: www.moni.rs
When setting google to images and search just that website (search for: "site:moni.rs") there are no images from gallery!??

Thanks in advance...

3 weeks 3 days ago #2

  • Artem's Avatar
  • Artem
  • Posts: 8638
Hi, Ivan!

Thank you for contacting us!

Google is indexing Gallery pictures, please check this post to be sure:
support.balbooa.com/forum/joomla-gallery...mages-indexing#15451

For better indexing, be sure that you have added Alt to your pictures

Regards,
Artem, Balbooa.com

3 weeks 3 days ago #3

  • Ivan's Avatar
  • Ivan
  • Posts: 12
Well saying that IS indexing isn't enough. As you can see for yourself it is NOT indexing images:

on neither websites I used your component:

www.fantasia.hr
www.moni.rs
www.regge.hr
www.polyagram.rs

and so on and so on... All images from those websites that aren't in Gallery ARE being indexed, and all images inside Gallery are not visible in the search results.

So a little bit of support setting your component to work and making them appear on search would be appreciated more than just saying "yes it is".

Thanks in advance

3 weeks 2 days ago #4

  • Artem's Avatar
  • Artem
  • Posts: 8638
Well saying that IS indexing isn't enough.

I show you a real example with a successful Google indexing. Work with SEO on your site to get results! As a minimum, you need to alt to your pictures!

Check your sitemap.xml, as you can see there is error
moni.rs/sitemap.xml

Regards,
Artem, Balbooa.com
Powered by Kunena Forum