Gridbox 2.7.2 and Personal Blog Theme Onefold

Continue Reading
Mon. - Fri. 9 am - 5 pm Support Policy
Remember me

back to the gallery after closing lightbox

3 months 1 day ago #1

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Hi,

we create lightboxes with some pictures. When you first scroll down to the bottom and then you scroll to top and close the window it does not lead back to the gallery overview. (portrait is displayed below the gallery...)

How we can go back to the gallery after closing lightbox?

logoform.agentur-komet.de

Username/Password: test

Best regards,
Klaus
Attachments:

3 months 23 hours ago #2

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
Hello,

This is related to the code in your template (the page can scroll even if the lightbox is open).


To solve this problem, you can add custom CSS code to your template use custom CSS file.
html {
    overflow-y: hidden !important;
}

body {
    overflow-y: auto !important;
    max-height: 100vh;
}

Regards,
Vyacheslav, Balbooa.com

3 months 23 hours ago #3

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Problem solved, thank you!

3 months 23 hours ago #4

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
You are welcome ;)

3 months 23 hours ago #5

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Oh, I think the code causes some issues ...

1. Effect is that the portraits below the gallery are scrolled
2. Mainmenu has no white background if you are scrolling down

Best regards,
Klaus
Attachments:

3 months 22 hours ago #6

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
This is due to a CSS code conflict with your template.
For header is needed
html {
    overflow-y: scroll;
}
.
But with this code you will not be able to stop scrolling the page with the lightbox open.

Regards,
Vyacheslav, Balbooa.com

3 months 20 hours ago #7

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Mmh, that does not really work ..

Could you perhaps enable only the lightbox area for scrolling at the time when lightbox is opened?

Best regards,
Klaus

3 months 20 hours ago #8

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
Scrolling only works in the lightbox area.
But if you scroll to top or bottom of lightbox (And nowhere else to scroll) - the page can scrolling

Regards,
Vyacheslav, Balbooa.com

3 months 20 hours ago #9

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Hello,

scrolling in the lightbox area is not working independently of scrolling the whole page in the background. When scrolling bottom down a scrollbar appears and then the whole page is starting to scroll.

It would be great if the "layer" of the lightbox area could be scrolled without having effects on the website in the background.

It would be fantastic if you have an idea how to solve this issue.

Best regards,
Klaus
Attachments:

3 months 19 hours ago #10

  • Artem's Avatar
  • Artem
  • Posts: 8359
Hi, Klaus!

We will be happy to provide you a solution, but since your template adding scroll to the tag HTML instead of the body we can't help you using CSS.

We can make changes in the Gallery, send us Joomla Super Admin or FTP, please use our contact form:
support.balbooa.com/contact-us

Regards,
Artem, Balbooa.com

3 months 18 hours ago #11

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Hi Artem,

great, now it works! Thank you very much!

There is only one issue: it causes that the page is "jumping" a bit to left when opening the lightbox and back to the right when closing the lightbox.

We had this issue before and I edited the following code in teh custom.css but now it does not help:

}
body.album-in-lightbox-open, body.modal-open {
width: auto;


Best regards,
Klaus

3 months 18 hours ago #12

  • Artem's Avatar
  • Artem
  • Posts: 8359
Try to replace to this one
body.modal-open {
    width: auto;
}

Regards,
Artem, Balbooa.com

3 months 17 hours ago #13

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Unfortunatley this code does not work ...
Attachments:

3 months 17 hours ago #14

  • Artem's Avatar
  • Artem
  • Posts: 8359
Sorry, I made a mistake! :whistle:

This should work
.modal-open {
    width: auto;
}

Regards,
Artem, Balbooa.com

3 months 17 hours ago #15

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Mmh, I changed the code and cleared the cache but unfortunatley I get the same issue ..
Attachments:

3 months 17 hours ago #16

  • Artem's Avatar
  • Artem
  • Posts: 8359
Also add this
.album-in-lightbox-open,
.modal-open {
    width: calc(100% - 15px) !important;
}

Regards,
Artem, Balbooa.com

3 months 17 hours ago #17

  • Klaus's Avatar
  • Klaus
  • Posts: 26
I add this code (view screenshot) but I´m sorry the issue remains ...

Kind regard,
Klaus
Attachments:

3 months 17 hours ago #18

  • Artem's Avatar
  • Artem
  • Posts: 8359
Okay, try in the code to replace 15 to 18

Regards,
Artem, Balbooa.com

3 months 16 hours ago #19

  • Klaus's Avatar
  • Klaus
  • Posts: 26
thanks, but nothing is changing ...

You can edit the custom.css in the back end with your admin login:




Best regarfds,
Klaus

2 months 4 weeks ago #20

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Hello,

is there anything new about the issue?

Best regards,
Klaus

2 months 4 weeks ago #21

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
Hello,
Thank you for contacting us

We have fixed an issue!
Changes we did in the files:
ba-gallery.js (/components/com_bagallery/assets/js/ba-gallery.js)
custom.css (/templates/jp-host/css/custom.css)

But after updating, the changes at the ba-gallery.js will be lost (we recommend keeping a backup copy of these files)

Regards,
Vyacheslav, Balbooa.com

2 months 4 weeks ago #22

  • Klaus's Avatar
  • Klaus
  • Posts: 26
Perfect :)

Thank you so much!

Best regards,
Klaus

2 months 4 weeks ago #23

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 6584
You are welcome ;)
Let us know if you need more assistance

Regards,
Vyacheslav, Balbooa.com
Powered by Kunena Forum