Crafted eCommerce Template

Crafted Joomla eCommerce template for kids store and baby shops
Mon. - Fri. 9 am - 5 pm Ask a Question
Remember me

the gallery is no longer displayed I get errors

1 month 1 week ago #1

  • nick's Avatar
  • nick
  • Posts: 35
Hello
My gallery is no longer displayed, I did not make any changes .
with firefox inspector , I have errors :

Uncaught ReferenceError: jQuery is not defined
<anonymous> https://wwwxxxxx/components/com_bagallery/assets/js/ba-gallery.js?2.3.1:8

Uncaught TypeError: $ is undefined
<anonymous> https://wwwxxxxxx/components/com_bagallery/libraries/ba_isotope/ba_isotope.js?2.3.1:260
<anonymous> https://wwwxxxx/components/com_bagallery/libraries/ba_isotope/ba_isotope.js?2.3.1:283

Uncaught TypeError: $ is undefined
<anonymous> https://wwwxxxx/components/com_bagallery/libraries/modal/ba_modal.js?2.3.1:39
<anonymous> https://wwwxxx/components/com_bagallery/libraries/modal/ba_modal.js?2.3.1:55

Thank you your help


Balbooa Joomla Gallery 2.3.1

1 month 1 week ago #2

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
Hello,
Thank you for contacting us

Send us a link to page with problem.
Send us FTP access and Joomla admin access via our contact form.
support.balbooa.com/contact-us

Regards,
Vyacheslav, Balbooa.com

1 month 1 week ago #3

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
You have disabled load jQuery in gallery settings.
We enabled it on and everything works well.


Best Regards,
Vyacheslav, Balbooa Support Team

1 month 1 week ago #4

  • nick's Avatar
  • nick
  • Posts: 35
well thank you but I did not make any changes . it's strange

I have a problem also with english version

www.xxxx/en/travel I have this code :

[gallery ID=3]

1 month 1 week ago #5

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
As we see you have disabled gallery ID = 3.
And as we wrote earlier, you have disabled load jQuery in gallery settings.




Regards,
Vyacheslav, Balbooa.com

1 month 1 week ago #6

  • nick's Avatar
  • nick
  • Posts: 35
thank you so much for your help

1 month 1 week ago #7

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
You are welcome ;)
Let us know if you need more assistance!

Best Regards,
Vyacheslav, Balbooa Support Team

1 month 1 week ago #8

  • nick's Avatar
  • nick
  • Posts: 35
sorry there is another problem to display photos
www.y-globetrotter.fr/en/travel?jordan&petra-wadi-rum
if i clic on one photo the photo do not load
my web site send me a mail :
Exception Type: <code>TypeError</code><br/>
File: /home/xxxxx/components/com_bagallery/controllers/gallery.php<br/>
Line: 1124<br/>
Message: imagesx(): Argument #1 ($image) must be of type GdImage, bool given
</p>
<pre>#0 /home/xxxxxx/components/com_bagallery/controllers/gallery.php(1124): imagesx()
#1 /home/xxxxxxx/libraries/src/MVC/Controller/BaseController.php(710): BagalleryControllerGallery->addWatermark()
#2 /home/xxxxxx/components/com_bagallery/bagallery.php(19): Joomla\CMS\MVC\Controller\BaseController->execute()
#3 /home/xxxxx/libraries/src/Component/ComponentHelper.php(402): require_once('/home/gaya0483/...')
#4 /home/xxxxx/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent()
#5 /home/xxxxx/libraries/src/Application/SiteApplication.php(194): Joomla\CMS\Component\ComponentHelper::renderComponent()
#6 /home/xxxxx/libraries/src/Application/SiteApplication.php(233): Joomla\CMS\Application\SiteApplication->dispatch()
#7 /home/xxxxx/libraries/src/Application/CMSApplication.php(203): Joomla\CMS\Application\SiteApplication->doExecute()
#8 /home/xxxxx/index.php(49): Joomla\CMS\Application\CMSApplication->execute()
#9 {main}</pre>

......

1 month 1 week ago #9

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
Hello,
Thank you for contacting us

You are using a non-existent picture as a watermark.
You need to re-select the watermark


Regards,
Vyacheslav, Balbooa.com

1 month 1 week ago #10

  • nick's Avatar
  • nick
  • Posts: 35
Thank you for your help

1 month 1 week ago #11

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
You are welcome ;)

1 month 1 week ago #12

  • nick's Avatar
  • nick
  • Posts: 35
I am sorry but I have the same problem, the picture for watermark is already added. I received a mail from my web site
<p>A PHP Exception occurred on your site. Here you can find the stack trace:</p>
<p>
Exception Type: <code>TypeError</code><br/>
File: /home/xxxxx/y-globetrotter.fr/components/com_bagallery/controllers/gallery.php<br/>
Line: 1126<br/>
Message: imagesx(): Argument #1 ($image) must be of type GdImage, bool given
</p>
<pre>#0 /home/xxxxx/y-globetrotter.fr/components/com_bagallery/controllers/gallery.php(1126): imagesx()
#1 /home/xxxx/y-globetrotter.fr/libraries/src/MVC/Controller/BaseController.php(710): BagalleryControllerGallery->addWatermark()
#2 /home/xxxxx/y-globetrotter.fr/components/com_bagallery/bagallery.php(19): Joomla\CMS\MVC\Controller\BaseController->execute()
#3 /home/xxxxx/y-globetrotter.fr/libraries/src/Component/ComponentHelper.php(402): require_once('/home/gaya0483/...')
#4 /home/xxxxx/y-globetrotter.fr/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent()
#5 /home/xxxxx/y-globetrotter.fr/libraries/src/Application/SiteApplication.php(194): Joomla\CMS\Component\ComponentHelper::renderComponent()
#6 /home/xxxxx/y-globetrotter.fr/libraries/src/Application/SiteApplication.php(233): Joomla\CMS\Application\SiteApplication->dispatch()
#7 /home/xxxxx/y-globetrotter.fr/libraries/src/Application/CMSApplication.php(203): Joomla\CMS\Application\SiteApplication->doExecute()
#8 /home/xxxxx/y-globetrotter.fr/index.php(49): Joomla\CMS\Application\CMSApplication->execute()
#9 {main}</pre>

1 month 1 week ago #13

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 17542
Hello,

Send us a link to page with problem.
Send us FTP access and Joomla admin access via our contact form.
support.balbooa.com/contact-us

Regards,
Vyacheslav, Balbooa.com
Powered by Kunena Forum