Introducing Balbooa Joomla Forms 2.x Beta

Continue Reading
Mon. - Fri. 9 am - 5 pm Ask a Question
Remember me

Multiple Page - No scroll on desktop/laptop

4 months 2 weeks ago #1

  • Matt's Avatar
  • Matt
  • Posts: 88
Hello Balbooa!

We are using the multiple page form and the scroll is not wanted on the desktop version of the site. How do we change this? Also, we want form to be static (not fade in).

4 months 2 weeks ago #2

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 8440
Hello,
Thank you for contacting us

Send us a link to page with forms

Regards,
Vyacheslav, Balbooa.com

4 months 2 weeks ago #3

  • Matt's Avatar
  • Matt
  • Posts: 88
Just sent URL via Contact Form.

4 months 2 weeks ago #4

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 8440
In order to remove the fade effect, at the code editor to add css code:
.com-baforms .ba-form > div,
.popup-form .ba-form > div {
	animation: none !important;
}
As for the scroll solution in this post
support.balbooa.com/forum/joomla-forms/7...lti-page-forms#34768

Regards,
Vyacheslav, Balbooa.com

4 months 2 weeks ago #5

  • Matt's Avatar
  • Matt
  • Posts: 88
We did the JS but it doesn't seem to make a difference. Is there a way to have that ONLY apply to desktop and laptop views?

4 months 1 week ago #6

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 8440
Hello,
Thank you for contacting us

You can disable the scroll only on all devices for this you need to delete the code (in two places)
            ba_jQuery('html, body').animate({
                scrollTop: position
            }, 'slow');
at the ba-form.js (/components/com_baforms/assets/js/ba-form.js)

After the update, all changes will be lost

Regards,
Vyacheslav, Balbooa.com
Powered by Kunena Forum