Miko. eCommerce Template

Mon. - Fri. 9 am - 5 pm Ask a Question
Remember me

Lots of Error/Wrnings after install

4 years 6 months ago #1

  • Craig's Avatar
  • Craig
Hi,

Just installed the Forms product and when opening the product get lots of errors/wanings.

Warning: simplexml_load_string(): Entity: line 37: parser error : Specification mandate value for attribute async in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): /scripts/cf.challenge.js" data-type="normal" data-ray="2f3e5f9c67af0a78" async in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): ^ in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): Entity: line 37: parser error : attributes construct error in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): /scripts/cf.challenge.js" data-type="normal" data-ray="2f3e5f9c67af0a78" async in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): ^ in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): Entity: line 37: parser error : Couldn't find end of Start Tag script line 37 in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): /scripts/cf.challenge.js" data-type="normal" data-ray="2f3e5f9c67af0a78" async in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): ^ in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Warning: simplexml_load_string(): Entity: line 37: parser error : Opening and ending tag mismatch: form line 36 and script in /var/sites/h/howerugby.co.uk/public_html/administrator/components/com_baforms/helpers/baforms.php on line 32

Any assistance on this?

Kind regards,
Craig

4 years 6 months ago #2

  • Artem's Avatar
  • Artem
  • Posts: 9069
Hi Craig,

Go to: /administrator/components/com_baforms/helpers/baforms.php
Line 27

Replace from:
    public static function checkUpdate($version)
    {
        $version = str_replace('.', '', $version);
        $url = 'http://www.balbooa.com/updates/baforms/com_baforms_update.xml';
        $curl = self::getContentsCurl($url);
        $xml = simplexml_load_string($curl);
        $newVersion = (string)$xml->version;
        $newVersion = str_replace('.', '', $newVersion);
        $exp = strlen($version);
        $pow = pow(10, $exp);
        $version = $version / $pow;
        $exp = strlen($newVersion);
        $pow = pow(10, $exp);
        $newVersion = $newVersion / $pow;
        if ($newVersion > $version) {
            return false;
        } else {
            return true;
        }
    }

to
    public static function checkUpdate($version)
    {
        return true;
        $version = str_replace('.', '', $version);
        $url = 'http://www.balbooa.com/updates/baforms/com_baforms_update.xml';
        $curl = self::getContentsCurl($url);
        $xml = simplexml_load_string($curl);
        $newVersion = (string)$xml->version;
        $newVersion = str_replace('.', '', $newVersion);
        $exp = strlen($version);
        $pow = pow(10, $exp);
        $version = $version / $pow;
        $exp = strlen($newVersion);
        $pow = pow(10, $exp);
        $newVersion = $newVersion / $pow;
        if ($newVersion > $version) {
            return false;
        } else {
            return true;
        }
    }

Why do you see this?!
By some reason, your hosting is blocking our Auto Updater, version checker

Let me know if you will need more help :)

Regards,

4 years 6 months ago #3

  • Craig's Avatar
  • Craig
The text you have asked to replace does not exist in the file mentioned.

I have installed on another site and get the same error and also can not create a new custom module.

Please refund the purchase as obviously the plugin does not work.

Kind regards,
Craig

4 years 6 months ago #4

  • Artem's Avatar
  • Artem
  • Posts: 9069
Send us please Joomla admin and FTP access, use our contact form:
support.balbooa.com/contact-us

Regards,
Powered by Kunena Forum