Remember me

Error log Google sheet PHP Deprecated

4 months 3 weeks ago #1

  • Tex's Avatar
  • Tex
  • Posts: 8
Hello, I have a Balboa form in bquobydominion.com/en/with-project (Joomla 4 PhP 8.1)

The integration with Google Sheets has been disrupted, and additionally, it's not sending messages to the administrators, although all submissions are still saved in the system.



Error 'PHP message: PHP Deprecated: Return type of Google\\Model::offsetExists($offset) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /usr/home/bquobydominion.com/web/components/com_baforms/libraries/google-v4/vendor/google/apiclient/src/Model.php on line 256PHP message: PHP Deprecated: Return type of Google\\Model::offsetGet($offset) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #


Can you tell me what could be the problem?

4 months 3 weeks ago #2

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
Hello,
Thank you for contacting us

It looks like the problem is related to the PHP version
groups.google.com/g/easy-appointments/c/Q_BfXNQyMRs

Regards,
Vyacheslav, Balbooa.com

4 months 3 weeks ago #3

  • Tex's Avatar
  • Tex
  • Posts: 8
Hello, I have the last version of Baforms. I don't have easy-appointments

4 months 3 weeks ago #4

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
Send us a link to page with problem.
Send us FTP access and Joomla admin access via our contact form.
support.balbooa.com/contact-us

Regards,
Vyacheslav, Balbooa.com

4 months 3 weeks ago #5

  • Tex's Avatar
  • Tex
  • Posts: 8
Could you tell me what you need to see and I give you? I can't give admin access.

4 months 3 weeks ago #6

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
You need to downgrade the PHP version to 7th,
Google library which added forms does not support 8 PHP
and disable the display of errors in the global configurations of joomla

Regards,
Vyacheslav, Balbooa.com

4 months 3 weeks ago #7

  • Tex's Avatar
  • Tex
  • Posts: 8
That's no possible! Joomla 4 needs php 8! Google library would be support 8php. You need update baform or is an error of google services?

4 months 3 weeks ago #8

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
Joomla 4 can work with versions older than 7.2.5
downloads.joomla.org/technical-requirements

Regards,
Vyacheslav, Balbooa.com

4 months 3 weeks ago #9

  • Tex's Avatar
  • Tex
  • Posts: 8
I know that works with older version but not in this website.
Going back with PHP is not a solution you can give me since otherwise we will have other compatibility problems with other components.
I write down the files that contain deprecate code in case you want to update them:

/com_baforms/libraries/google-v4/vendor/google/apiclient/src/Model.php
/com_baforms/libraries/google-v4/vendor/google/apiclient/src/Collection.php

4 months 3 weeks ago #10

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
We will take this into consideration

Best Regards,
Vyacheslav, Balbooa Support Team
Powered by Kunena Forum