Remember me

Conditional logic not working

5 months 4 weeks ago #1

  • IEEE MS's Avatar
  • IEEE MS
  • Posts: 3
Hi,
i'm missing something when configuring conditional logic on my form.
I've an item with 6 possible values, depending on the value I hide or show different fields.
What i did is for each value, i make a rule to hide and show the specific values, but it seems that only the last rule is working by default.
I didn't find another way to make this working.

Any help is welcome

5 months 4 weeks ago #2

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
Hello,
Thank you for contacting us

Your rules override each other, there is no need to make a rule to hide a field if there is a rule that makes it visible (the field will be hidden until the rule is executed)
We do not recommend using the same fields in different rules to avoid confusion.

Regards,
Vyacheslav, Balbooa.com

5 months 4 weeks ago #3

  • IEEE MS's Avatar
  • IEEE MS
  • Posts: 3
So what is the best way. I've 6 options, and 6 groups of fields to show and hide depending on the options.
Is option 1 is selected, the group 1 is shown and others no. If option 2 is selected, the group 1 and 2 is shown and the others no, ......

Please help me to find the best way. I bought the components for this option. :-)

5 months 4 weeks ago #4

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
Example
Rule 1
If option 1 is selected
If option 2 is selected
If option 3 is selected
...
any
group 1 displayed

Rule 2
If option 2 is selected
If option 3 is selected
...
any
group 2 displayed

5 months 3 weeks ago #5

  • IEEE MS's Avatar
  • IEEE MS
  • Posts: 3
Worked fine. Thank you for your help

5 months 3 weeks ago #6

  • Viacheslav's Avatar
  • Viacheslav
  • Posts: 28858
You are welcome ;)
Please feel free to ask any questions.
Have a nice day!

Best Regards,
Vyacheslav, Balbooa Support Team
Powered by Kunena Forum