Mon. - Fri. 9 am - 5 pm Ask a Question
Remember me

Form lost on upgrade from 1.7.4 Pro to 2.0.4 Pro

1 month 5 hours ago #1

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
I had a working form, with conditional logic, using version 1.7.4 Pro. When I upgrade to 2.0.4 Pro the form entry is in the list, but the form editor page is blank and the form does not display on the front-end. If I re-install 1.7.2 (I don't have a zip for 1.7.4), then form is restored in the back-end and front-end.

Do I need to do something special to migrate a 1.7.4 form to 2.0.4?

Thanks, Chris

4 weeks 2 days ago #2

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Hello,

Thank you for contacting us!

You need to update your forms, clear your cache,
If this does not help send us a link to page with problem.
Send us FTP access and Joomla admin access via our contact form.
support.balbooa.com/contact-us

Regards,
Vyacheslav, Balbooa.com

4 weeks 1 day ago #3

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
Clearing the cache did not solve the problem.

Sorry, I am not posting that information in a public forum, and the Contact Us link does not provide an email address for you!

Can I send you the exported 1.7.4 form?

Chris

4 weeks 1 day ago #4

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Hello,

Contact us via our contact form.
support.balbooa.com/contact-us

Regards,
Vyacheslav, Balbooa.com

3 weeks 2 days ago #5

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
I sent an export of the 1.7.4 form with the error messages I am seeing when I import into 2.0.4. When can I expect a reply?

Or do I have to re-build this complex form in 2.0.4 from scratch?

Thanks, Chris

3 weeks 2 days ago #6

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Hello,

Thank you for contacting us!

We answered your email

Send us a link to page with problem.
Send us FTP access and Joomla admin access

Regards,
Vyacheslav, Balbooa.com

3 weeks 2 days ago #7

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
Sorry I cannot do that due to the presence of confidential client information.

I already sent you a copy of the form exported from the working 1.7.4 installation. Please confirm that you can load that into a 2.0.4 installation, because when I do so I get errors (already sent to you) and both the back-end form editor and the fornt-end form display are blank.

Thanks, Chris

3 weeks 2 days ago #8

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Send us the attached file

Best Regards,
Vyacheslav, Balbooa Support Team

3 weeks 2 days ago #9

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
This forum does not alllow the attachment of .xml files, and the contact form does not support attachments, so I pasted the xml file into the body of the contact form. You are making this hard.

3 weeks 2 days ago #10

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Upload the file to the file hosting service and send us a link to this file

Best Regards,
Vyacheslav, Balbooa Support Team

3 weeks 2 days ago #11

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
What file hosting service?

3 weeks 2 days ago #12

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Any file storage service.

3 weeks 2 days ago #13

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
There is no way to export / import forms that have different version.
You need to update to the same version and then import

Best Regards,
Vyacheslav, Balbooa Support Team

3 weeks 2 days ago #14

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
That was the first thing I did. I updated the Forms extension from 1.7.4 to 2.0.4 on a copy of the live website and from that point I was unable to edit the form or display it on the front-end.

If you still want me to send to a copy of the form via a file transfer service I need an email address for you. When I asked that earlier in this thread you advised me to use the Contact Us page which is just a web form! I pasted the xml of the form there. Why was that not good enough?

Please clarify how your support sevice is supposed to work. Your good product is being spoilt by a clunky support framework.

Thanks, Chris

3 weeks 2 days ago #15

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
We checked the update, everything works well, the form is being edited (you can see it in the video).
nimb.ws/jI6R3H

In order to find out the reason why it does not work on your site, we need access, perhaps it is a conflict with one of your extensions, you can also try to update manually.
support.balbooa.com/forum/joomla-forms/9...forms-1-update#44876

Best Regards,
Vyacheslav, Balbooa Support Team

3 weeks 2 days ago #16

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
You misundertstand.

All ypour video shows is that the update process work. I know that. I am not saying that the Forms update fails. I have successfully updated the copy website from Forms 1.7.4 to Forms 2.0.4 and can create new forms there. However, I am unable to edit or display the existing form.

Please answer how I can send you the failing form by file transfer service if I do not have an email address for you.

Thanks, Chris

3 weeks 2 days ago #17

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
The video shows that the form is edited after the update.

You can upload it to Google Drive and submit a link to the file,
this file should be exported from the latest version of the forms.
Only with this file, we are unlikely to be able to figure out the reason,
we need to see the site (access is needed)

Best Regards,
Vyacheslav, Balbooa Support Team

3 weeks 1 day ago #18

  • Chris Dee's Avatar
  • Chris Dee
  • Posts: 16
Thanks for your help so far.

I have now been able to access the old form in the 2.0.4 editor (by exporting and re-importing), and may have found the problem. In 1.7.4 it was possible to have a fixed text area (called a content editor field) displayed conditionally depending on the value of a select field. On conversion to 2.0.4 these fields become Text fields and the conditional logic is lost. Although the conditional input fields work, no conditional logic is applied to the text areas and all text areas appear on the front-end form regardless of the selected value. In fact I can't see how to make a text file display conditionally. If I add a new rule in Conditional Logic, I don't see the text field in the list of selectable fields for a Show Field action.

Is it no longer possible to display a different text area for different values of the select field? Is there another technique to achieve that?

Thanks, Chris

3 weeks 1 day ago #19

  • Vyacheslav's Avatar
  • Vyacheslav
  • Posts: 11557
Hello,
Thank you for contacting us

It's great that you found the solution yourself.
Conditional logic does not work with text for this you need to use headline
support.balbooa.com/forum/joomla-forms/9...ns-fields-text#44505

Best Regards,
Vyacheslav, Balbooa Support Team
Powered by Kunena Forum