Remember me

sitemap.xml not reachable

9 months 1 week ago #1

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi!
I have a small issue and dont know how to handle it.
I have generated the sitemap.xml but when I try to pen the file or add it to Google Search Console the URL is not reachable....
schmucktapeten.de/sitemap.xml
I have no idea where I am making something wrong. Could you help me with it please?

Thanks!
Lukas

9 months 1 week ago #2

  • Artem's Avatar
  • Artem
  • Posts: 11342
Hi Lukas,

Send us a link to the site.

Regards,
Artem, Balbooa.com

9 months 6 days ago #3

  • Lukas's Avatar
  • Lukas
  • Posts: 213
schmucktapeten.de
or du you need admin access?

9 months 4 days ago #4

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Artem I have also noticed some errors and strange redirections since upgrade to multicategory version...and the site suddenly became very slow. The loading time is terrible. Would you check on it if possible please?

9 months 4 days ago #5

  • Lukas's Avatar
  • Lukas
  • Posts: 213
and oft first loading ended like this. First after page refresh it loads properly.
Attachments:

9 months 4 days ago #6

  • Lukas's Avatar
  • Lukas
  • Posts: 213
exactly here :)
Attachments:

9 months 4 days ago #7

  • Artem's Avatar
  • Artem
  • Posts: 11342
Hello Lukas,

1. Sitemap - does the file sitemap.xml in the root of your Joomla is available?
2. Favicon Errors - Try to install latest Gridbox version 2.16.1.1
3. Are you using multiple categories on site?

Yes, send us Joomla admin access:
support.balbooa.com/contact-us

Regards,
Artem, Balbooa.com

9 months 4 days ago #8

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem,
sorry for late respond. I am not getting the e-mails anymore when you answer:(

so here your questions :)
1. yes it is in the root and can be opened. with rights 644
2. the newest gridbox is already installed. I even downloaded it manually and installed it again.
3. yes, a lot :) on this website each product is assigned at least to 3-4 categories.

and since the multicategorisation, the loading time is just dramatical, although I have all the Performance tools activated.... I can clearly say this happend as soon as I installed the 16.0.1.1

9 months 4 days ago #9

  • Lukas's Avatar
  • Lukas
  • Posts: 213
all the access data I have already sent to you yesterday by the issue with undefined checkout button...

9 months 2 days ago #10

  • Lukas's Avatar
  • Lukas
  • Posts: 213
I really hope you could help me with this issue, as this shop is not gonna sell anything with 10sek loading time :( I have no idea what to do :(

9 months 1 day ago #11

  • Lukas's Avatar
  • Lukas
  • Posts: 213
just as a hint... I have also made a langing page on the same website of course with gridbox, which points to one of the products from the shop....
schmucktapeten.de/guido-maria-kretschmer-fashion-for-walls-3
this page is opening almost with normal speed...
I even check the Hosting Parameters, but there everything seems to fine....

9 months 1 day ago #12

  • Lukas's Avatar
  • Lukas
  • Posts: 213
just wanted to ask if something is happening on the site :( I dont want to stress you r something, but this unexpectable issue is blocking us from starting a marketing campaign and start to sell....

kindly give me a feedback on it please.

Lukas

9 months 1 day ago #13

  • Artem's Avatar
  • Artem
  • Posts: 11342
Lukas,

At the moment solution can be only one - disable multi-categories! It's question not for one day and quickly can't be fixed.

Regards,
Artem, Balbooa.com

9 months 1 day ago #14

  • Lukas's Avatar
  • Lukas
  • Posts: 213
hi,
ok....damn...that is what I was worry about :(
but I will make it as you suggest and wait till you find a way to handle it,
thank you Artem for your update on it.

best wishes
Lukas

9 months 1 day ago #15

  • Artem's Avatar
  • Artem
  • Posts: 11342
New info - slow speed is not related to multicategories!!! I have exported your eCommerce app to my side. Work fast, even without optimisation.


I'm continue working

9 months 1 day ago #16

  • Lukas's Avatar
  • Lukas
  • Posts: 213
hmm as you can see I have allready disabled the undercategories....i still think it is related to multicategories, because on our server it is also working a bit faster now....I have disabled all the undercategories and assigned about 20 prducts now to just one main category-

9 months 1 day ago #17

  • Lukas's Avatar
  • Lukas
  • Posts: 213
now it opens after ca. 4 sek....so just like on yours, when you add all the pictures :D

9 months 1 day ago #18

  • Artem's Avatar
  • Artem
  • Posts: 11342
Yes, you are right, the issue is related to multi-categories, on my side multi-categories were disabled

9 months 1 day ago #19

  • Artem's Avatar
  • Artem
  • Posts: 11342
Regarding the sitemap.

What file permissions has sitemap.xml file (644)?
I can't check on my side, since the FTP access doesn't work

Regards,
Artem, Balbooa.com

9 months 1 day ago #20

  • Rim's Avatar
  • Rim
  • Posts: 63
We also have a problem with sitemap.xml, in webmastertools there is information that the "failed to read the map".

9 months 1 day ago #21

  • Rim's Avatar
  • Rim
  • Posts: 63
We have 644

9 months 1 day ago #22

  • Artem's Avatar
  • Artem
  • Posts: 11342
Rim,

Do you can open your sitemap in browser?
www.yoursite.com/sitemap.xml

Regards,
Artem, Balbooa.com

9 months 1 day ago #23

  • Rim's Avatar
  • Rim
  • Posts: 63
yes: atrakcjeturystyczne.eu/sitemap.xml

9 months 1 day ago #24

  • Artem's Avatar
  • Artem
  • Posts: 11342
Your sitemap is absolutely valid. You can test here: www.xml-sitemaps.com/validate-xml-sitemap.html Try to submit it to Google

Regards,
Artem, Balbooa.com

9 months 1 day ago #25

  • Rim's Avatar
  • Rim
  • Posts: 63
Same thing.



9 months 1 day ago #26

  • Lukas's Avatar
  • Lukas
  • Posts: 213
it is 644 by me...

9 months 1 day ago #27

  • Lukas's Avatar
  • Lukas
  • Posts: 213
i just logged to sftp with those creditionals...
Attachments:

9 months 19 hours ago #28

  • Artem's Avatar
  • Artem
  • Posts: 11342
Lukas, Link should be visible.

So, at the moment I have only one thought - some kind of protection which blocks viewing file. Try to disable Admin tools and other protection tools (maybe you have added something to .htaccess)

Regards,
Artem, Balbooa.com

9 months 19 hours ago #29

  • Artem's Avatar
  • Artem
  • Posts: 11342
Rim,

Try to test map in URL Inspection Tool
support.google.com/webmasters/answer/9012289?hl=en

Regards,
Artem, Balbooa.com

9 months 17 hours ago #30

  • Rim's Avatar
  • Rim
  • Posts: 63

9 months 17 hours ago #31

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem,
Admin Tools is already deactivated, but maybe it left some input in robot.txt or htaccess....I will check on it :)
thank you for your assist on it!
more important indeed is the multicategorization and loading speed issue :)
Now I have about 50% of the products assigned to single category and the page loads much faster already:)

I knew it was to beautiful to be true with the multicategories....and I remember when you answered someone here that it is a very very complex task and you need to be careful with it :)

Anyway I still am convinced that Balbooa Team is the best Joomla Dev and Support Team ever !

So thumbs up! take your time! and don't change!

Lukas

9 months 14 hours ago #32

  • Artem's Avatar
  • Artem
  • Posts: 11342
Lukas,

Do you have any copy of site with assigned multi-categories? I have assigned to 5-10 categories to each product, but site is not so slow as it was on your side, take a look:

balbooa.com/dev/store-app/multicategories/uni-tapeten


9 months 11 hours ago #33

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem,
so in Akeeba Backup the last backup from Friday should be with all the categories assigned to products...and the slowest version :) You can download it from backend without problems.
Could we please continue to communicate via E-Mails? I am not getting any notification when you are answering now :( The E-Mails I can answer directly day & night :)

8 months 4 weeks ago #34

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Good morning Artem!
Yesterday evening I have installed the "old" version of the website on my own vps server with better performance but it is also very slow... you can check it here:
tapeten.lukas.design

The access is the same as the other website.

regards
Lukas

8 months 4 weeks ago #35

  • Artem's Avatar
  • Artem
  • Posts: 11342
Hi Lukas,

There is some redirect, when I try visit tapeten.lukas.design it redirects me to schmucktapeten.de
Disable redirect and send us Joomla admin from tapeten.lukas.design :)

Regards,
Artem, Balbooa.com

8 months 4 weeks ago #36

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi,
yes I have also detect the redirection...but there is no redirection configured in Joomla. I am thinking about Admin Tools and changes it made to htaccess and configuration.php etc...but this was disabled all the time now :(
The redirection from tapeten.lukas.design appeared when I disabled the Lets Encrypt SSL for this domain... also strange thing :( I have enabled the SSL again and it works.

We have change the max redirection parameter on our server to see what happens...we changed it to 30 but still in logs we could find errors and wornings about limits....but we have no redirections activated anywhere :(

the admin access for you is the same on both websites.

8 months 4 weeks ago #37

  • Lukas's Avatar
  • Lukas
  • Posts: 213
I have now all the products assigned to just one category each and the site is working much faster. Also I have uninstalled Admin Tools Extension on schmucktapeten.de

8 months 4 weeks ago #38

  • Artem's Avatar
  • Artem
  • Posts: 11342
Okay, we'll work on your side. I'll contact if we'll find solution :)

Regards,
Artem, Balbooa.com

8 months 4 weeks ago #39

  • Lukas's Avatar
  • Lukas
  • Posts: 213
ok. do you need sftp and Data Base access to tapeten.lukas.design ?

8 months 4 weeks ago #40

  • Artem's Avatar
  • Artem
  • Posts: 11342
Ready, you can try:
tapeten.lukas.design/alle-tapeten/tag/guido-maria-kretschmer

To fix on main website:

1. Download and unzip:
drive.google.com/file/d/1fcz5L11ALwd6D5F...MlY/view?usp=sharing

2. Upload files:
editor.php - /components/com_gridbox/controllers
gridbox.php - /components/com_gridbox/helpers

Regards,
Artem, Balbooa.com

8 months 4 weeks ago #41

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem!
this is a great news! Fantastic! Thank you!!!
The site is mega fast now:) can I ask you what was the problem?

However the server where tapeten.lukas.design is hosted logs some errors with internal redirections amount. We already adjust this parameter but still unusual amount...you can see it here:

[Wed Sep 13 22:56:54.072533 2023] [core:error] [pid 1543628] [client 217.254.249.104:38484] AH00124: Request exceeded the limit of 30 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: tapeten.lukas.design/mustertapeten/10299-47-focus
[Wed Sep 13 22:57:07.190396 2023] [core:error] [pid 1543634] [client 217.254.249.104:59636] AH00124: Request exceeded the limit of 30 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: tapeten.lukas.design/alle-tapeten/naturals/betonoptik
root@web01:~#


Do you have any idea why is it happening?

a huge thank you Artem!

Lukas

And both sites have 4 errors that can be checked in a console... screenshot 2.
Attachments:

8 months 4 weeks ago #42

  • Artem's Avatar
  • Artem
  • Posts: 11342
Hello,

1. As I can see in Google, the issue is related to rules in .htaccess file. You can contact your hosting support.

2. The issue with favicon (console errors), as a sitemap, is related to some protection from server side "403 forbidden".

Regards,
Artem, Balbooa.com

8 months 4 weeks ago #43

  • Lukas's Avatar
  • Lukas
  • Posts: 213
ok you are the greatest of all..
I will check on those points. I think it was indeed the Admin Tools that made those changes, but after uninstallation did not reverse them....

Do you maybe have a good written htaccess ? :D

regards
Lukas

8 months 4 weeks ago #44

  • Artem's Avatar
  • Artem
  • Posts: 11342
Lukas,

Move back .htaccess to original, and after that add new string and check frontend, step by step

Regards,
Artem, Balbooa.com

8 months 3 weeks ago #45

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem!
as you adviced I have reconstructed the .htaccess file and no errors are displayed in the console now. :)
But now I am missing the favicon. none of the browsers is displaying it.
I have also enabled all the compressing tools, but the PageSpeed insights are very very poor....I have no Idea what I can do more :(
Would you help me with better resoults pleaase?as you made for one user in another post?
Thank you in advance!
Lukas
Attachments:

8 months 3 weeks ago #46

  • Lukas's Avatar
  • Lukas
  • Posts: 213
Hi Artem,
I know I am annoying but I have to inform you:

1. sitemap.xml is working good. is accessable and google could read it. Great! :woohoo:
2. the performance of the site is terrible...ok it is not 14 sek as before, but as soon as I added the products to multi categories the loading time was more than 3sek...which is unacceptable for e-commerce...
It is not a metter of the Server becuase I have checked it on two different, from different providers, one of them a strong VPS which is tuned by us....
3. the resoults by PageSpeed Instights are very bad....

schmucktapeten.de and tapeten.lukas.design...two different servers, both sites are with your edited php files you sent me... the first one is 1 article = 1 Category, the second shop is still with multicategories...

I have no idea what I can do more and how :(

please help!
Lukas
Powered by Kunena Forum